Is anyone using Spring 3 yet?

I noticed that Junit 4.5 is incompatible with Spring 2.5.6 (specifically SpringJUnit4ClassRunner in spring-test).

The quick solution is to downgrade back to Junit 4.4. But there’s some pretty cool stuff (e.g. @Rule) in the latest version of Junit.

I understand that Spring 3.0.0 is compatible with the latest version of Junit so long as you’re prepared to monkey around with your pom to make the hibernate, cgilib and asm dependencies happy. Is anyone using Spring 3?

It's only fair to share...
Share on FacebookGoogle+Tweet about this on TwitterShare on LinkedIn

Leave a Reply